NONMEM Users Network Archive

Hosted by Cognigen

Re: g77 Problem

From: andreas.krause
Date: Mon, 28 Jun 2010 17:15:28 +0200

Lloyd,

the linker seems unable to find the library files to link them all
together with your code.
I suspect there are some environment variables missing on your system.
Open a DOS window and enter set

If you do not see a line that looks similar to
LIBRARY_PATH=c:\g77\g77-2.95-mrg\lib
that might well be the problem.
You should also have an entry in PATH similar to c:\g77\g77-2.95-mrg\bin

Right-click on "My computer", select System Properties, Advanced,
Environment variables, and add the specs for your system.

        Andreas






"Lloyd Whitfield" <lwsolutions
Sent by: owner-nmusers
06/28/2010 04:14 PM

To
<nmusers
cc

Subject
[NMusers] g77 Problem






I have been using NONMEM VI with the g77 Fortran compiler on a Dell laptop=
 
running Vista since last year with no problems. After not using NONMEM
for some time, I tried to run a previously successful control file
yesterday and the job wouldn?t run. I suspected that the problem might be=
 
with the g77 compiler so I attempted to test g77 installation by creating=
 
and running the ?hello.for? test file as described in the NONMEM
installation instructions. When I attempted to compile the file from a DOS=
 
command, I got the following:
 
 
C:\nmvi2\run>g77 hello.for -o hello.exe
Info: resolving __fmode by linking to __imp___fmode (auto-import)
Info: resolving __fpreset by linking to __imp___fpreset (auto-import)
C:/PHSTMinGW/bin/../lib/gcc/mingw32/3.4.5/../../../crt2.o:crt1.c:(.text+0x3=
7):
u
ndefined reference to `__cpu_features_init'
C:/PHSTMinGW/bin/../lib/gcc/mingw32/3.4.5/../../../crt2.o:crt1.c:(.text+0x8=
9):
u
ndefined reference to `_pei386_runtime_relocator'
fu000001.o:(.idata$2+0xc): undefined reference to `libmsvcrt_a_iname'
fu000002.o:(.idata$2+0xc): undefined reference to `libmsvcrt_a_iname'
fu000004.o:(.idata$2+0xc): undefined reference to `libmsvcrt_a_iname'
fu000005.o:(.idata$2+0xc): undefined reference to `libmsvcrt_a_iname'
nmth000000.o:(.idata$4+0x0): undefined reference to `_nm___fmode'
nmth000003.o:(.idata$4+0x0): undefined reference to `_nm___fpreset'
collect2: ld returned 1 exit status
 
C:\nmvi2\run>
 
I reinstalled the g77 compiler and ran the hello.for file and got the
same message again as shown above. As I have had a problem with bad RAM on=
 
the laptop before, I tested the RAM and found that the ram was fine. I
have no idea what the message means. If anyone has had this experience
before or could offer a suggestion on what I might try to overcome the
problem, I would be greatly appreciate any suggestions.
 
 
Thanks,
Lloyd Whitfield



The information of this email and in any file transmitted with it is strict=
ly confidential and may be legally privileged.
It is intended solely for the addressee. If you are not the intended recipi=
ent, any copying, distribution or any other use of this email is prohibited=
 and may be unlawful. In such case, you should please notify the sender imm=
ediately and destroy this email.
The content of this email is not legally binding unless confirmed by letter.
Any views expressed in this message are those of the individual sender, exc=
ept where the message states otherwise and the sender is authorised to stat=
e them to be the views of the sender's company. For further information abo=
ut Actelion please see our website at http://www.actelion.com
Received on Mon Jun 28 2010 - 11:15:28 EDT

The NONMEM Users Network is maintained by ICON plc. Requests to subscribe to the network should be sent to: nmusers-request@iconplc.com.

Once subscribed, you may contribute to the discussion by emailing: nmusers@globomaxnm.com.